re = /(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)/m
str = 'RR1234567890120'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end