import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(RR|IR|US|BUG|VUL)(\\d{13,14})|(TX|WI|DTS)(\\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\\d{14})|(#)(\\d+)";
final String string = "RR1234567890120";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}