import re
regex = re.compile(r"(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)", flags=re.MULTILINE)
test_str = "RR1234567890120"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")