package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)`)
var str = `RR1234567890120`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}