$re = '/(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)/m';
$str = 'RR1234567890120';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);