const regex = /(RR|IR|US|BUG|VUL)(\d{13,14})|(TX|WI|DTS)(\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\d{14})|(#)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(RR|IR|US|BUG|VUL)(\\d{13,14})|(TX|WI|DTS)(\\d{13})|(DTS[a-zA-Z0-9]{19})|(SR)(\\d{14})|(#)(\\d+)', 'gm')
const str = `RR1234567890120`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}