# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?LU2w26227 (.*?) Belob.*/$1/gm;t' <<< "ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad"