// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?LU2w26227 (.*?) Belob.*").unwrap();
let string = "ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}