package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?LU2w26227 (.*?) Belob.*`)
var str = `ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}