re = /.*?LU2w26227 (.*?) Belob.*/m
str = 'ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result