using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?LU2w26227 (.*?) Belob.*";
string substitution = @"$1";
string input = @"ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}