import Foundation
let pattern = #".*?LU2w26227 (.*?) Belob.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)