$re = '/.*?LU2w26227 (.*?) Belob.*/m';
$str = 'ABC This is an example Vores ref.: 23244-2234 LW782837673 LU2w26227 Ole Hansen s.r.t Belob to: sajsad';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;