#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!([\u4e00-\u9fa5]|\w+))."
Local $sString = "汉字测试通过 123 2" & @CRLF & _
"12313" & @CRLF & _
"sfdsdfs--" & @CRLF & _
"😂自行车🚲" & @CRLF & _
"----" & @CRLF & _
"[`~!@%#$^&*()=|{}':;', \\[\\]<>/? /\]\\.;:%……+ ¥()【】‘”“'.。,、?1234567890-=_+~?!@#$%^&*)]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")