import re
regex = re.compile(r"(?!([\u4e00-\u9fa5]|\w+)).")
test_str = ("汉字测试通过 123 2\n"
"12313\n"
"sfdsdfs--\n"
"😂自行车🚲\n"
"----\n"
"[`~!@%#$^&*()=|{}':;', \\\\[\\\\]<>/? /\]\\\\.;:%……+ ¥()【】‘”“'.。,、?1234567890-=_+~?!@#$%^&*)]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")