using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!([\u4e00-\u9fa5]|\w+)).";
string input = @"汉字测试通过 123 2
12313
sfdsdfs--
😂自行车🚲
----
[`~!@%#$^&*()=|{}':;', \\[\\]<>/? /\]\\.;:%……+ ¥()【】‘”“'.。,、?1234567890-=_+~?!@#$%^&*)]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}