const regex = /(?!([\u4e00-\u9fa5]|\w+))./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!([\\u4e00-\\u9fa5]|\\w+)).', 'g')
const str = `汉字测试通过 123 2
12313
sfdsdfs--
😂自行车🚲
----
[\`~!@%#\$^&*()=|{}':;', \\\\[\\\\]<>/? /\]\\\\.;:%……+ ¥()【】‘”“'.。,、?1234567890-=_+~?!@#$%^&*)]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}