re = /(?!([\u4e00-\u9fa5]|\w+))./
str = '汉字测试通过 123 2
12313
sfdsdfs--
😂自行车🚲
----
[`~!@%#$^&*()=|{}\':;\', \\\\[\\\\]<>/? /\]\\\\.;:%……+ ¥()【】‘”“\'.。,、?1234567890-=_+~?!@#$%^&*)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end