$re = '/(?!([\u4e00-\u9fa5]|\w+))./';
$str = '汉字测试通过 123 2
12313
sfdsdfs--
😂自行车🚲
----
[`~!@%#$^&*()=|{}\':;\', \\\\[\\\\]<>/? /\]\\\\.;:%……+ ¥()【】‘”“\'.。,、?1234567890-=_+~?!@#$%^&*)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);