using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s+(\S+)\s+\((.*)\)\s+IN\s+'(.*)'\s+of type\s+'(.*)'\s+\]";
string input = @"[ condition12 (BRAND) IN 'Beats by Dr. Dre & D\'Silva of type Band' of type 'IDENTIFIER_STRING' ]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}