$re = '/\[\s+(\S+)\s+\((.*)\)\s+IN\s+\'(.*)\'\s+of type\s+\'(.*)\'\s+\]/';
$str = '[ condition12 (BRAND) IN \'Beats by Dr. Dre & D\\\'Silva of type Band\' of type \'IDENTIFIER_STRING\' ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);