import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s+(\\S+)\\s+\\((.*)\\)\\s+IN\\s+'(.*)'\\s+of type\\s+'(.*)'\\s+\\]";
final String string = "[ condition12 (BRAND) IN 'Beats by Dr. Dre & D\\'Silva of type Band' of type 'IDENTIFIER_STRING' ]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}