const regex = /\[\s+(\S+)\s+\((.*)\)\s+IN\s+'(.*)'\s+of type\s+'(.*)'\s+\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s+(\\S+)\\s+\\((.*)\\)\\s+IN\\s+\'(.*)\'\\s+of type\\s+\'(.*)\'\\s+\\]', 'g')
const str = `[ condition12 (BRAND) IN 'Beats by Dr. Dre & D\\'Silva of type Band' of type 'IDENTIFIER_STRING' ]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}