// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\s+(\S+)\s+\((.*)\)\s+IN\s+'(.*)'\s+of type\s+'(.*)'\s+\]").unwrap();
let string = "[ condition12 (BRAND) IN 'Beats by Dr. Dre & D\\'Silva of type Band' of type 'IDENTIFIER_STRING' ]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}