re = /\[\s+(\S+)\s+\((.*)\)\s+IN\s+'(.*)'\s+of type\s+'(.*)'\s+\]/
str = '[ condition12 (BRAND) IN \'Beats by Dr. Dre & D\\\'Silva of type Band\' of type \'IDENTIFIER_STRING\' ]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end