package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\s+(\S+)\s+\((.*)\)\s+IN\s+'(.*)'\s+of type\s+'(.*)'\s+\]`)
var str = `[ condition12 (BRAND) IN 'Beats by Dr. Dre & D\'Silva of type Band' of type 'IDENTIFIER_STRING' ]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}