#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S+=\"[^"]+\")|(\S+=\S+)"
Local $sString = " ReinfOpt="FE Design" MinReinfT=0.0018 MinReinfC=0" & @CRLF & _
" Column=C1200x3500 Type=Rectangular Color=Magenta Notes="Added 4/4/2018 12:27:15 PM"" & @CRLF & _
" Slab="S10 staircase" Type=Slab Color=16777088 Notes="Added 4/4/2018 11:41:05 AM"" & @CRLF & _
" Slab="S10 staircase" Type=Slab MatProp=C45 Thickness=10 Ortho=No"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")