# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'(\S+=\"[^"]+\")|(\S+=\S+)'
test_str = (" ReinfOpt=\"FE Design\" MinReinfT=0.0018 MinReinfC=0\n"
" Column=C1200x3500 Type=Rectangular Color=Magenta Notes=\"Added 4/4/2018 12:27:15 PM\"\n"
" Slab=\"S10 staircase\" Type=Slab Color=16777088 Notes=\"Added 4/4/2018 11:41:05 AM\"\n"
" Slab=\"S10 staircase\" Type=Slab MatProp=C45 Thickness=10 Ortho=No")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.