import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S+=\\\"[^\"]+\\\")|(\\S+=\\S+)";
final String string = " ReinfOpt=\"FE Design\" MinReinfT=0.0018 MinReinfC=0\n"
+ " Column=C1200x3500 Type=Rectangular Color=Magenta Notes=\"Added 4/4/2018 12:27:15 PM\"\n"
+ " Slab=\"S10 staircase\" Type=Slab Color=16777088 Notes=\"Added 4/4/2018 11:41:05 AM\"\n"
+ " Slab=\"S10 staircase\" Type=Slab MatProp=C45 Thickness=10 Ortho=No";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}