use strict;
my $str = ' ReinfOpt="FE Design" MinReinfT=0.0018 MinReinfC=0
Column=C1200x3500 Type=Rectangular Color=Magenta Notes="Added 4/4/2018 12:27:15 PM"
Slab="S10 staircase" Type=Slab Color=16777088 Notes="Added 4/4/2018 11:41:05 AM"
Slab="S10 staircase" Type=Slab MatProp=C45 Thickness=10 Ortho=No';
my $regex = qr/(\S+=\"[^"]+\")|(\S+=\S+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}