re = /(\S+=\"[^"]+\")|(\S+=\S+)/
str = ' ReinfOpt="FE Design" MinReinfT=0.0018 MinReinfC=0
Column=C1200x3500 Type=Rectangular Color=Magenta Notes="Added 4/4/2018 12:27:15 PM"
Slab="S10 staircase" Type=Slab Color=16777088 Notes="Added 4/4/2018 11:41:05 AM"
Slab="S10 staircase" Type=Slab MatProp=C45 Thickness=10 Ortho=No'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end