using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+=\""[^""]+\"")|(\S+=\S+)";
string input = @" ReinfOpt=""FE Design"" MinReinfT=0.0018 MinReinfC=0
Column=C1200x3500 Type=Rectangular Color=Magenta Notes=""Added 4/4/2018 12:27:15 PM""
Slab=""S10 staircase"" Type=Slab Color=16777088 Notes=""Added 4/4/2018 11:41:05 AM""
Slab=""S10 staircase"" Type=Slab MatProp=C45 Thickness=10 Ortho=No";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}