const regex = new RegExp('(\\S+=\\"[^"]+\\")|(\\S+=\\S+)', 'g')
const str = ` ReinfOpt="FE Design" MinReinfT=0.0018 MinReinfC=0
Column=C1200x3500 Type=Rectangular Color=Magenta Notes="Added 4/4/2018 12:27:15 PM"
Slab="S10 staircase" Type=Slab Color=16777088 Notes="Added 4/4/2018 11:41:05 AM"
Slab="S10 staircase" Type=Slab MatProp=C45 Thickness=10 Ortho=No`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}