# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[Link\][\s\S]*?\.pdf\s//g;t' <<< "[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua."