$re = '/\[Link\][\s\S]*?\.pdf\s/';
$str = '[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;