const regex = /\[Link\][\s\S]*?\.pdf\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[Link\\][\\s\\S]*?\\.pdf\\s', 'g')
const str = `[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);