package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[Link\][\s\S]*?\.pdf\s`)
var str = `[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}