using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Link\][\s\S]*?\.pdf\s";
string substitution = @"";
string input = @"[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}