import Foundation
let pattern = #"\[Link\][\s\S]*?\.pdf\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[Link]
2017_07_11_RM_4b.pdf
Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)