#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[Link\][\s\S]*?\.pdf\s"
Local $sString = "[Link]" & @CRLF & _
"2017_07_11_RM_4b.pdf" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)