using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^@([^(]*)\(([^=]*)=""(.*?)"",\s+([^=]*)=([^)]*)\)";
string substitution = @"$1 $2 $3 $4 $5";
string input = @"@Apple(kind=""Bax"", priority=33)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}