const regex = /^@([^(]*)\(([^=]*)="(.*?)",\s+([^=]*)=([^)]*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^@([^(]*)\\(([^=]*)="(.*?)",\\s+([^=]*)=([^)]*)\\)', 'gm')
const str = `@Apple(kind="Bax", priority=33)`;
const subst = `$1 $2 $3 $4 $5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);