use strict;
my $str = '@Apple(kind="Bax", priority=33)';
my $regex = qr/^@([^(]*)\(([^=]*)="(.*?)",\s+([^=]*)=([^)]*)\)/mp;
my $subst = '$1 $2 $3 $4 $5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";