import Foundation
let pattern = #"^@([^(]*)\(([^=]*)="(.*?)",\s+([^=]*)=([^)]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"@Apple(kind="Bax", priority=33)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3 $4 $5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)