# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\S)[^\S\n]*\[[^][\n]*]$//gm;t' <<< "First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]
[Ignore This Part]"