$re = '/(?<=\S)[^\S\n]*\[[^][\n]*]$/m';
$str = 'First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]
[Ignore This Part]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;