import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\S)[^\\S\\n]*\\[[^][\\n]*]$";
final String string = "First string\n"
+ "Second string [Ignore This Part]\n"
+ "Third string (1) [Ignore This Part]\n\n\n"
+ " [Ignore This Part]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}