re = /(?<=\S)[^\S\n]*\[[^][\n]*]$/m
str = 'First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]
[Ignore This Part]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result