using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\S)[^\S\n]*\[[^][\n]*]$";
string substitution = @"";
string input = @"First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]
[Ignore This Part]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}