use strict;
my $str = 'First string
Second string [Ignore This Part]
Third string (1) [Ignore This Part]
[Ignore This Part]';
my $regex = qr/(?<=\S)[^\S\n]*\[[^][\n]*]$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";